Mikrotik несколько isp одновременно. Мульти WAN.

Зачем нужен MultiWAN
• Для резервирования подключения к Интернет через нескольких провайдеров
• Для распределения нагрузки между несколькими провайдерами
• Для доступа к маршрутизатору через несколько внешних каналов

Основная проблема связана с тем, что пакет приходит на
один из интерфейсов маршрутизатора, а маршрутизатор
может ответить с другого интерфейса, если имеется более
выгодный маршрутю.

Как настроить Микрот чтоб ответ маршрутизатора шел с правильного интерфейса?
• Маркировать маршрут в Mangle (только цепочки Prerouting и Output)
• Воспользоваться командой /ip route rule
• Воспользоваться action=route в mangle prerouting

Классический вариант решения задачи это
• Маркировка соединения в Mangle Input
• Маркировка маршрута в Mangle Output
• Создание маркированных маршрутов в /ip route

/ip firewall mangle
add action=mark-connection chain=input in-interface=ether1-WAN1 \
 new-connection-mark=con-WAN1 passthrough=yes
add action=mark-connection chain=input in-interface=ether2-WAN2 \
 new-connection-mark=con-WAN2 passthrough=yes
add action=mark-routing chain=output connection-mark=con-WAN1 \
 new-routing-mark=WAN1 passthrough=yes
add action=mark-routing chain=output connection-mark=con-WAN2 \
 new-routing-mark=WAN2 passthrough=yes
/ip route
add distance=1 gateway=1.1.1.1 routing-mark=WAN1
add distance=1 gateway=2.2.2.1 routing-mark=WAN2
add distance=1 gateway=1.1.1.1
add distance=2 gateway=2.2.2.1