Mikrotik блокируем доступ по url - доменному имени (запрещаем одноклассники, вконтакте)

Будем блокировать доступ к YouTube, Одноклассник-ам подменяя DNS - записи.

Очевидно что работать это будет только если пользователи используют DNS сервер нашего микротика.

/ip dns static
add address=127.0.0.1 disabled=no name=".*\\(^\\|\\.\\)odnoklassniki\\.ru" ttl=1d
add address=127.0.0.1 disabled=no name="youtube\\.com" ttl=1d
В данном примере мы блокирум одноклассники и все его поддомены, и только основной домен ютуба.

It анекдот

Встречаются два программиста:

- Говорят, ты женился!

- Да, есть такое дело.

- А как зовут?

- (в задумчивости) Окс.. нет, Тат..., КОРОЧЕ ICQ# 98760138109