cisco

Сброс на дефолтные настройки Cisco Catalyst Switch 3560 3650 3750 2900 ( Reset factory defaults Cisco Catalyst Switch 3560 3650 3750 2900 series)

1 Удаляем информацию о виланах

cisco-catalyst-reset-default#delete flash:vlan.dat
Delete filename [vlan.dat]?
Delete flash:/vlan.dat? [confirm]
cisco-catalyst-reset-default#

>>

Cisco dhcp. Зарезервировать mac ip адрес. Удалить резервацию.

Например, нам надо создать резервацию для принтера на циске.

Зарезервируем за неким mac адресом (mac-ом принтера) ip адрес 192.168.0.100

ip dhcp pool PRINTER
   host 192.168.0.100 255.255.255.0
   client-identifier 0178.e7d1.aa8f.5d
   default-router 192.168.0.1
   dns-server 192.168.0.1
   lease 60
!

>>

Конфигурируем TFTP опцию для автоматической раздачи DHCP клиентам

Конфигурируем TFTP опцию для автоматической раздачи DHCP клиентам

Cisco Router TFTP Option Server on DHCP Configuration

>>

Два провайдера, Cisco, route-map и ip sla (настройка cisco 2 провайдера )

Policy Based Routing with the Multiple Tracking Options Feature Configuration Example

Итак у нас 2 канала:

  • ISP1 подключен к FastEthernet0/0, шлюз x.x.x.1
  • ISP2 подключен к FastEthernet0/1, шлюз y.y.y.1

Локальная сеть:

  • Vlan1 192.168.0.0/24

>>

GRE Tunnel Keepalives

GRE Tunnel Keepalives

Router# configure terminal
Router(config)#interface tunnel0
Router(config-if)#keepalive 5 4          

!--- The syntax of this command is keepalive [seconds [retries]].



!--- Keepalives are sent every 5 seconds and 4 retries.
!--- Keepalives must be missed before the tunnel is shut down.
!--- The default values are 10 seconds for the interval and 3 retries.
Document ID: 64565 http://www.cisco.com/en/US/tech/tk827/tk369/technologies_tech_note09186a008048cffc.shtml

Как не потерять cisco из-за не правильных настроек

Чтоб не потерять циску, можно задать ей перезагрузку по таймауту командой reload in N. После введения этой команды циска автоматически перезагрузится через N минут c текущим startup-config.

Итак задаём перезагрузку через 10 минут.

router#reload in ?
	Delay before reload (mmm or hhh:mm)
router#reload in 10
	System configuration has been modified. Save? [yes/no]: n
	Reload scheduled in 10 minutes by root on vty4 (192.168.0.1)
	Reload reason: Reload Command
	Proceed with reload? [confirm]y

Далее делаем все необходимые изменения, НЕ!!! сохраняя конфиг. Проверяем что мы не потеряли управление.

>>

Cisco Router. Перенаправляем http трафик на прокси сервер (NAT and redirect на Transparent Proxy)

!
interface Ethernet0/0
 ip address 10.0.0.1 255.255.255.0
 ip policy route-map proxy-redirect
!
access-list 120 remark www_acl
access-list 120 deny   tcp host 10.0.0.254 any
access-list 120 permit tcp 10.0.0.0 0.0.0.255 any eq www
access-list 120 deny   ip any any
!
route-map proxy-redirect permit 10
 match ip address 120
 set ip next-hop 10.0.0.254
!

>>

Cisco PPPoE client (ADSL, xDSL)

!
vpdn enable
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
!
interface FastEthernet4
 no ip address
 no ip mroute-cache
 no keepalive
 pppoe enable
 pppoe-client dial-pool-number 1
 no cdp enable
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 ip nat outside
 encapsulation ppp
 no ip mroute-cache
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username u$ername password pa$$word
!
access-list 2 permit 192.168.0.0 0.0.0.255
!
ip nat inside source list 2 interface Dialer1 overload
!
dialer-list 1 protocol ip permit
!

Display interface SNMP IfIndex

Display interface SNMP IfIndex

router#show snmp mib ifmib ifindex

>>

Проблема DF бита и фрагментации в IPsec / GRE туннелях ( clear df bit dlink )

Если браузер не открывает Web-страницы или не передаются файлы по протоколу FTP, то возможно вы столкнулись с проблемой фрагментации пакетов.

C:\>ping mail.ru -l 1500 -f
Pinging mail.ru [94.100.191.204] with 1500 bytes of data:
Packet needs to be fragmented but DF set.
...
C:\>ping mail.ru -l 1500 -f
Обмен пакетами с mail.ru [94.100.191.204] по 1500 байт:
Требуется фрагментация пакета, но установлен запрещающий флаг.
...

Одним из решений этой проблемы (проблема DF бита) является использование полиси роутинга (PBR), для сброса бита DF в IP пакетах.

>>

  • Страница 2 из 2
  • 1
  • 2

It анекдот

Мой сын точно будет хакером - он еще в презервативе нашел уязвимость.