Пример настройки OSPF на маршрутизаторах Cisco

Итак приступим
!
conf t
ip routing
ip subnet-zero
ip classless
ip cef
!
!
conf t
int vlXXX
ip ospf message-digest-key 1 md5 12345
ip ospf network point-to-point
!

main router

!
conf t
router ospf 10
log-adjacency-changes
!Зададим RID 255.255.255.255, для того чтобы данный маршрутизатор 
!при выборах DR и BDR всегда выбирался как DR 
!(у кого больший router-id тот и победит в выборах за место DR в сети если у 
!всех маршрутизаторов одинаковый приоритет), а так же потом будет легко его определять 
!( в выводах show команд) по этому номеру RID как «верхний» маршрутизатор
router-id 255.255.255.255
!Включаем принудительное подавление OSPF обновлений на всех интерфейсах
passive-interface default
!Разрешаем обмен OSPF обновлениями через нужный интерфейс
no passive-interface vlXXX
!Анонсируем по OSPF сеть 192.168.0.0/32 в области 0 (BACKBONE) 
!(Будут проаносированы все подсети попадающие под маску /32)
network 192.168.0.0 0.0.0.3 area 0.0.0.0
!Включаем постоянную генерацию маршрута по умолчанию
default-information originate always
!		

spoke router

!
conf t
router ospf 1
router-id 192.168.0.2
log-adjacency-changes detail
passive-interface default
no passive-interface vlXXX
network 192.168.0.0 0.0.0.255 area 0.0.0.0

Debug'им

    debug ip ospf
    debug ip ospf adj
    debug ip ospf hello
    debug ip ospf events
    debug ip ospf packet

Ну и читаем лучший сайт про сиськи ;)

Troubleshooting OSPF Document ID: 12151 http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a00800949f7.shtml

It анекдот

Только программисты могли додуматься заклеивать обоями окна.